New Owner

For practicing posting messages and becoming familiar with the forum.

Moderator: Ron Spiker

New Owner

Postby Randy Strock » Sun Oct 18, 2009 6:26 pm

Hello Everyone. I'm the proud new owner of a Brantly B2B. I purchased 2297U, serial # 470, from Mike Orlowski in West Plains, MO. (JettStar poster id...he's posted here previously). very nice fellow. We flew it, I bought it. I have moved it currently to Dutch Country Helicopters at the Lancaster Airport. They taught me to fly in a Bell 47. Anyway...now that we're going over the ship, we have discovered a non site specific small oil leak that is in the area of the engine. Here's the question - Any suggestions on how to best access the entire area for inspection? It sure doesn't look easy to get to. I don't want to discover a hairline cylinder crack or something of that nature the hard way. (I am NOT suggesting that anything was wrong with the purchase transaction). Just being very cautious. Any suggestions on how to go about uncovering the engine for inspection without taking the whole thing apart will be greatly appreciated. Thanks. Randy Strock, Conowingo, MD 410 658 8500 work email is randystrock@infratech-mfg.com cell 443 807 0443
Randy Strock
 
Posts: 20
Joined: Sun Oct 11, 2009 12:52 pm

Re: New Owner

Postby bryancobb » Mon Oct 19, 2009 8:11 pm

Congrats Randy,

I had a finicky little oil leak on my ship even after a top O/H. Here's what I found out about how to prevent oil from collecting on the ledges in the engine compartment.

1) Idling is bad.
2) Immediately after engine start and visible rise in oil pressure, rotor brake off, go to 1900 rpm for warmup.
3) After landing, to shut down... 1900 rpm till CHT begins to drop, then throttle off and immediately mixture lean.

It seems to be that the exhust valve cooling oil seeps by the exhaust valves at idle. It doesn't get burned or blown through the exhaust at idle so it runs out the first joints in the exhaust system and drips or splatters into the engine compartment.

After I started doing this... vavoom no oil.

This may not be your problem but it worked for MY issue.

Bryan Cobb
YHO-3BR Pilots International
User avatar
bryancobb
 
Posts: 283
Joined: Thu Feb 27, 2003 8:23 pm
Location: Cartersville, Georgia

Re: New Owner

Postby Randy Strock » Tue Oct 20, 2009 5:15 pm

Hi Bryan.
Thank you for the suggestion. Since there was a series of short time startup, fly it onto the flatbed truck, startup, and fly it off, its a real possibility that's the problem. I sure hope so. I'm intending to take some electrical contact cleaner, which has a low flash point, and clean up the area, then see what happens.
and the saga continues.....
Randy
Randy Strock
 
Posts: 20
Joined: Sun Oct 11, 2009 12:52 pm

Re: New Owner

Postby HELISCAN » Sun Oct 25, 2009 10:15 am

Be sure that you do not have the old cork valve cover gaskets. If so replace.

Dave
HELISCAN
 
Posts: 67
Joined: Thu Sep 06, 2007 8:42 pm
Location: CHATTANOOGA


Return to Try It Out!

Who is online

Users browsing this forum: No registered users and 1 guest

cron