Magnetos

Service and maintenance tips, questions, and issues.

Moderator: Ron Spiker

Magnetos

Postby seneca2e » Sat Oct 27, 2012 3:28 pm

Just a little update on N7WE. I had a pretty sizable mag drop on the right mag. New plugs and a check of the harness(it was good) yielded nothing so I removed the right mag. This helicopter has got to be the hardest machine to work on ever built. It's almost like they designed it for a one time use lol. Working thru that small hole is just nearly impossible. But not quite-it can be done but just barely. Anyway after removing the mag I replaced the distributor block, points, and condenser, set them to open precisely at the egap and then tried to reinstall it. Could not be done! Just not enough "throw" in the bendix mags(they have a slot instead of a clamp that limits their adjustability). Everytime you got it in there it wouldn't time to the engine. Finally had to remove the main gear and rotate it 180 degrees. It has an odd number of teeth and that gives you a half tooth different orientation and that was what it took to do it! It went on and timed right up with the engine set to 25 degrees BTDC. Other problem was on removal the mag cap was frozen to the mag and wouldn't release. It had to be forced apart and that ruined the ends. Had to put all new ends on the harness cap(removed two sparkplug wires and fished it out the side where we cut it off). Then we replaced two wires on the bench and the other two standing beside the helicopter then fished it back in place. Also adjusted the left magneto to specs and checked the angle on the retard points(25 degrees after the main points open)-it was right on but the main mag points opened several degrees retarded(engine firing at about 20 degrees I'd estimate). Anyway got everything back together and just have to run it next monday to see if I did any good. Man that Robinson is looking better all the time :) .
seneca2e
 
Posts: 389
Joined: Mon Feb 11, 2008 10:35 pm

Re: Magnetos

Postby bryancobb » Sat Oct 27, 2012 7:32 pm

OH BUDDY!!! I empathize with you. I can remember my fat butt being up inside the baggage box trying to get those things in and timed! You were on the ball to catch the gear being the problem. I hope Monday gets you a home run.
YHO-3BR Pilots International
User avatar
bryancobb
 
Posts: 283
Joined: Thu Feb 27, 2003 8:23 pm
Location: Cartersville, Georgia

Re: Magnetos

Postby seneca2e » Sat Nov 03, 2012 6:25 am

Finally got to ground run it. The magneto issue is fixed! Almost sounds funny now to switch it to the right magneto and not have it drop 500 rpm lol.
seneca2e
 
Posts: 389
Joined: Mon Feb 11, 2008 10:35 pm

Re: Magnetos

Postby Ron Spiker » Sat Nov 03, 2012 4:05 pm

Good for you! Glad you got it.
User avatar
Ron Spiker
Site Admin
 
Posts: 527
Joined: Sat Mar 22, 2003 5:33 pm
Location: Pittsburgh, PA


Return to Servcing and Maintaining

Who is online

Users browsing this forum: No registered users and 1 guest

cron